Microsoft.AspNetCore.Blazor.Cli 0.5.1 ist nicht kompatibel mit netcoreapp2.0

asp.net-core blazor visual-studio webassembly

Frage

Ich habe Visual Studio 2017 und .net Core 2.1 aber immer noch nicht in der Lage, es laufen zu lassen.

Während ich ein Projekt erstelle, habe ich diesen Fehler bekommen. Microsoft.AspNetCore.Blazor.Cli 0.5.1 ist nicht kompatibel mit netcoreapp2.0

Bildbeschreibung hier eingeben

Überprüfen Sie die folgenden verfügbaren .net-Kern-SDKs und Laufzeiten sind

Bildbeschreibung hier eingeben

Beliebte Antwort

Ab Version 0.5.0 zielt das CLI-Paket auf .NET Core 2.1 und nicht auf .NET Core 2.0 ab. Sie müssen das Element <TargetFramework> in Ihrer csproj-Datei auf netcoreapp2.1 wenn Sie dieses Paket verwenden möchten.

Ich frage mich jedoch, warum würden Sie eine Abhängigkeit von diesem Paket nehmen? Es ist ein globales Werkzeug. Sie sollten wahrscheinlich Pakete wie Microsoft.AspNetCore.Blazor.Build , Microsoft.AspNetCore.Blazor.Browser usw. einschließen.




Lizenziert unter: CC-BY-SA with attribution
Nicht verbunden mit Stack Overflow
Ist diese KB legal? Ja, lerne warum
Lizenziert unter: CC-BY-SA with attribution
Nicht verbunden mit Stack Overflow
Ist diese KB legal? Ja, lerne warum