Microsoft.AspNetCore.Blazor.Cli 0.5.1 n'est pas compatible avec netcoreapp2.0

asp.net-core blazor visual-studio webassembly

Question

J'ai Visual Studio 2017 et .net Core 2.1, mais je ne parviens toujours pas à le faire fonctionner.

Pendant la création du projet, l'erreur Microsoft.AspNetCore.Blazor.Cli 0.5.1 n'est pas compatible avec netcoreapp2.0.

entrez la description de l'image ici

Vérifiez que les kits de développement logiciel (SDK) et les runtime ci-dessous sont disponibles.

entrez la description de l'image ici

Réponse populaire

À partir de la version 0.5.0, le package CLI cible .NET Core 2.1 plutôt que .NET Core 2.0. Vous devrez mettre à jour l'élément <TargetFramework> dans votre fichier netcoreapp2.1 vers netcoreapp2.1 si vous souhaitez utiliser ce package.

Je me demande cependant, pourquoi prendriez-vous une dépendance sur ce paquet? C'est un outil global. Vous devriez probablement inclure des packages tels que Microsoft.AspNetCore.Blazor.Build , Microsoft.AspNetCore.Blazor.Browser , etc.




Sous licence: CC-BY-SA with attribution
Non affilié à Stack Overflow
Est-ce KB légal? Oui, apprenez pourquoi
Sous licence: CC-BY-SA with attribution
Non affilié à Stack Overflow
Est-ce KB légal? Oui, apprenez pourquoi