.NET Blazor Build error

asp.net-core blazor

Domanda

Ho provato a eseguire l'applicazione Blazor per provare C # WebAssembly. Sto incontrando problemi quando cerco di eseguirlo in modi diversi. Ho anche provato a hackerare il runtimeconfig.json base a questo https://github.com/dotnet/cli/issues/7543

Esecuzione di IIS Express

inserisci la descrizione dell'immagine qui

Esecuzione di BlazorApplication1 Il programma '[42032] dotnet.exe' è terminato con il codice -2147450749 (0x80008083).

Esecuzione in riga di comando Non è stato possibile trovare alcuna versione di framework compatibile. Il framework specificato 'Microsoft.NETCore.App', versione '2.0.0-preview3-25512-01' non è stato trovato. - Verifica le dipendenze dell'applicazione e scegli come target una versione di framework installata su: \ - In alternativa, installa la versione di framework '2.0.0-preview3-25512-01'.

Risposta popolare

Devi avere l'anteprima 2.1 del framework core .net installato per Blazor per funzionare: scarica qui




Autorizzato sotto: CC-BY-SA with attribution
Non affiliato con Stack Overflow
È legale questo KB? Sì, impara il perché
Autorizzato sotto: CC-BY-SA with attribution
Non affiliato con Stack Overflow
È legale questo KB? Sì, impara il perché