Come installare ASP.NET Core Blazor Language Services quando non si utilizza VS 2017?

blazor c# visual-studio-2017 visual-studio-extensions

Domanda

Sto imparando come costruire un'applicazione Blazor da questo tutorial . Gli strumenti richiesti sono dati come segue.

  • Installare .NET Core 2.1 SDK (2.1.300-preview2-008533 o successivo).
  • Installare Visual Studio 2017 (15.7 Anteprima 5 o successiva) con ASP.NET e carico di lavoro di sviluppo Web selezionato.
  • Installa l'ultima estensione di Blazor Language Services dal Marketplace di Visual Studio.

Perché scaricare e installare VS 2017 richiede molto tempo, ho appena installato l'SDK. Ho anche scaricato il servizio di lingua (file .vsix ) ma non so come installarlo.

I seguenti passaggi sono riusciti.

md test
cd test


dotnet new -i Microsoft.AspNetCore.Blazor.Templates
dotnet new blazor -o ba1
cd ba1

Ma il seguente

md test
cd test


dotnet new -i Microsoft.AspNetCore.Blazor.Templates
dotnet new blazor -o ba1
cd ba1

produce un errore come segue:

CSC: errore CS1617: opzione non valida '7.3' per / langversion. Usa '/ langversion :?' per elencare i valori supportati. [C: \ Users \ AMD \ test \ BA1 \ ba1.csproj]

Domanda

Sembra che ho bisogno di installare il servizio di lingua, ma come può essere fatto senza VS 2017?

modificare

Per aver risposto al commento, perché non ho installato VS 2017 e suppongo (non lo ritengo in realtà) facoltativo, vedi l'estratto tratto dal tutorial.

inserisci la descrizione dell'immagine qui

Risposta accettata

Il servizio di lingua è per intellisense in Visual Studio. Quindi, se non si utilizza Visual Studio, non è necessario installarlo. Al momento non esiste un supporto intellisense per VSCode o qualcosa del genere.

Vedi qui per l'errore 7.3.




Autorizzato sotto: CC-BY-SA with attribution
Non affiliato con Stack Overflow
È legale questo KB? Sì, impara il perché
Autorizzato sotto: CC-BY-SA with attribution
Non affiliato con Stack Overflow
È legale questo KB? Sì, impara il perché