Microsoft.AspNetCore.Blazor.Cli 0.5.1 non è compatibile con netcoreapp2.0

asp.net-core blazor visual-studio webassembly

Domanda

Ho Visual Studio 2017 e. Netto core 2.1 ma ancora non riesco a farlo funzionare.

Mentre sto creando un progetto ho ricevuto questo errore Microsoft.AspNetCore.Blazor.Cli 0.5.1 non è compatibile con netcoreapp2.0

inserisci la descrizione dell'immagine qui

Controlla quanto segue Disponibili gli SDK e gli Runtime principali .net

inserisci la descrizione dell'immagine qui

Risposta popolare

A partire dalla versione 0.5.0 il pacchetto CLI è destinato a .NET Core 2.1 piuttosto che a .NET Core 2.0. Dovrai aggiornare l'elemento <TargetFramework> nel tuo file netcoreapp2.1 su netcoreapp2.1 se vuoi usare questo pacakge.

Mi chiedo però, perché dovresti prendere una dipendenza da questo pacchetto? È uno strumento globale. Probabilmente dovresti includere pacchetti come Microsoft.AspNetCore.Blazor.Build , Microsoft.AspNetCore.Blazor.Browser , ecc.




Autorizzato sotto: CC-BY-SA with attribution
Non affiliato con Stack Overflow
È legale questo KB? Sì, impara il perché
Autorizzato sotto: CC-BY-SA with attribution
Non affiliato con Stack Overflow
È legale questo KB? Sì, impara il perché