Microsoft.AspNetCore.Blazor.Cli 0.5.1은 netcoreapp2.0과 호환되지 않습니다.

asp.net-core blazor visual-studio webassembly

문제

나는 Visual Studio 2017과 .net core 2.1을 가지고 있지만 여전히 실행시킬 수는 없다.

프로젝트를 만드는 동안이 오류가 발생했습니다. Microsoft.AspNetCore.Blazor.Cli 0.5.1은 netcoreapp2.0과 호환되지 않습니다.

여기에 이미지 설명을 입력하십시오.

사용 가능한 .net 핵심 SDK 및 런타임은 다음과 같습니다.

여기에 이미지 설명을 입력하십시오.

인기 답변

버전 0.5.0부터 CLI 패키지는 .NET Core 2.0이 아닌 .NET Core 2.1을 대상으로합니다. 이 pacakge를 사용하려면 csproj 파일의 <TargetFramework> 요소를 netcoreapp2.1netcoreapp2.1 해야합니다.

나도 궁금해. 왜이 꾸러미에 의존하니? 그것은 세계적인 도구입니다. Microsoft.AspNetCore.Blazor.Build , Microsoft.AspNetCore.Blazor.Browser 등과 같은 패키지를 포함해야합니다.




아래 라이선스: CC-BY-SA with attribution
와 제휴하지 않음 Stack Overflow
이 KB는 합법적입니까? 예, 이유를 알아보십시오.
아래 라이선스: CC-BY-SA with attribution
와 제휴하지 않음 Stack Overflow
이 KB는 합법적입니까? 예, 이유를 알아보십시오.