Microsoft.AspNetCore.Blazor.Cli 0.5.1 несовместим с netcoreapp2.0

asp.net-core blazor visual-studio webassembly

Вопрос

У меня есть визуальная студия 2017 и .net core 2.1, но я все еще не могу ее запустить.

Пока я создаю проект, я получил эту ошибку. Microsoft.AspNetCore.Blazor.Cli 0.5.1 несовместим с netcoreapp2.0

введите описание изображения здесь

Проверьте ниже. Доступны SDK SDK и Runtimes.

введите описание изображения здесь

Популярные ответы

Начиная с версии 0.5.0 пакет CLI нацелен на .NET Core 2.1, а не на .NET Core 2.0. Вам нужно будет обновить элемент <TargetFramework> в файле csproj netcoreapp2.1 если вы хотите использовать этот pacakge.

Интересно, почему, зачем вы зависите от этого пакета? Это глобальный инструмент. Вероятно, вы должны включать такие пакеты, как Microsoft.AspNetCore.Blazor.Build , Microsoft.AspNetCore.Blazor.Browser и т. Д.



Лицензировано согласно: CC-BY-SA with attribution
Не связан с Stack Overflow
Является ли этот КБ законным? Да, узнайте, почему
Лицензировано согласно: CC-BY-SA with attribution
Не связан с Stack Overflow
Является ли этот КБ законным? Да, узнайте, почему