Microsoft.AspNetCore.Blazor.Cli 0.5.1與netcoreapp2.0不兼容

asp.net-core blazor visual-studio webassembly

我有視覺工作室2017和.net核心2.1但仍然無法讓它運行。

我正在創建項目時出現此錯誤Microsoft.AspNetCore.Blazor.Cli 0.5.1與netcoreapp2.0不兼容

在此處輸入圖像描述

檢查以下可用的.net核心SDK和運行時

在此處輸入圖像描述

熱門答案

從版本0.5.0開始,CLI包的目標是.NET Core 2.1而不是.NET Core 2.0。如果要使用此netcoreapp2.1則必須將csproj文件中的<TargetFramework>元素更新為netcoreapp2.1

我不知道,為什麼你會依賴這個包?這是一個全球性的工具。您應該包括Microsoft.AspNetCore.Blazor.BuildMicrosoft.AspNetCore.Blazor.Browser等軟件包。




許可下: CC-BY-SA with attribution
不隸屬於 Stack Overflow
這個KB合法嗎? 是的,了解原因
許可下: CC-BY-SA with attribution
不隸屬於 Stack Overflow
這個KB合法嗎? 是的,了解原因